Cómo instalar Trelby 2.2 en Ubuntu 16.04 y superiores

Photo credit: Fábio Telles via Foter.com / CC BY-NC

Debido a un fallo no corregido en la publicación de Trelby 2.2 para Debian y las distros derivadas, el paquete instalador .deb no se ejecutará correctamente en Ubuntu 16.04 o superiores, ya que tiene marcada como dependencia python-wxgtk2.8, la cual no está en los repositorios de Ubuntu 16.04 o superiores, sino la versión 3.0. Además, aunque corrijas esta dependencia manualmente, va a instalarse pero Trelby va a tener un error al iniciarse y no se va a poder utilizar.

Pero tranquilo. Aquí llega la explicación de cómo instalarlo de tal manera que quede completamente funcional.

Licencia Creative Commons
Esta obra está bajo una Licencia Creative Commons Atribución-CompartirIgual 4.0 Internacional. Si usted cree que en esta bitácora se está vulnerando su derecho de autor, por favor, siéntase libre de ponerse en contacto conmigo por medio de esta bitácora y lo solucionaremos.

Hay dos maneras de hacerlo, la difícil y la fácil.

Solución difícil

Seguir las instrucciones que se encuentran en http://askubuntu.com/questions/785399/trelby-not-installing-in-16-04

Dichas instrucciones dicen:

1) descargar de aquí el archivo tar.gz y descomprimirlo

2) modificar estos 3 archivos, tal como se muestra en las imágenes, eliminando las líneas marcadas con rojo y añadiendo las líneas de color verde:

src/cfgdlg.py

screenshot-at-2016-11-12-231349

src/config.py

Screenshot at 2016-11-12 23:15:10.png

src/trelby.py

Screenshot at 2016-11-12 23:15:34.png

3) modificar las dependencias del programa. El principio es el mismo que puedes ver aquí

4) compilar e instalar la aplicación. Si no sabes cómo hacer esto pasa por aquí

Solución fácil

1) descargar el archivo .deb adjunto en el comentario que encontramos en https://groups.google.com/forum/#!topic/trelby/_u7-h46c4x8

2) en una terminal

$ sudo dpkg -i /rutadelarchivodescargado/nombredelarchivodescargado.deb

Veremos que se instala sin problema

3) luego veremos que se ha creado una entrada de nombre “Trelby” en Menú –> Accesorios, pero al clicarlo no hace nada. También es posible que no exista acceso directo alguno. De cualquier forma podemos editar la entrada “Trelby” o crear una que apunte a la ruta “/usr/bin/trelby”. Si la probamos veremos que Trelby se inicia y funciona

4) veremos que la entrada “Trelby” en el menú aparece sin icono. Eso lo podemos arreglar editando dicha entrada y escogiendo el icono de sombrero que nos guste de la ruta “/usr/share/trelby/resources/”. Y he aquí Trelby funcionando:

Trelby 2.2
Trelby 2.2 funcionando

Listo. Ya podemos escribir guiones de películas.

Photo credit: Fábio Telles via Foter.com / CC BY-NC

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s